[Request] NVMe BIOS for HP Z620

Hi, looking to mod a HP Z620 with 3.91 BIOS (3.94 is latest) I’d like to add an NVMe driver and update microcodes for Xeon E5-1620v2 CPUID 306E4 (SR1AR)

I have an SPI programmer and waiting for a chip clip for SOIC 16, from this thread: BIOS Mod Requested for HP Z420 with LGA 2011 Socket, Intel C602 Chipset and HP Motherboard it sounds like there is a software method to bypass BIOS flash lock.

HP Z620 BIOS links:
3.91 https://ftp.hp.com/pub/softpaq/sp78001-78500/sp78209.tgz
3.94 https://ftp.hp.com/pub/softpaq/sp88501-89000/sp88962.tgz

EDIT by Fernando: Since this thread has nothing to do with the topic “Storage Drivers”, I have moved it into the “BIOS Modding Requests” Sub-Forum.

I was able update the microcode and add NVMe to another BIOS and it booted successfully using UBU v1.74.0.3 and UEFITool 0.26.0

Trying to get one thing working at a time… following the guide here : [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS I added the NVMe DXE to 3.94 BIOS after the last DXE.

To sanity check I tried with UEFITool 0.26.0 (recommended in NVMe guide) and UEFITool 0.22.3 (recommended in microcode guide), however they give me differing BIOS:

Screen Shot 2019-06-19 at 12.11.27 AM.png



I’ll stick with 0.26.0 and try to flash it using the software method if I figure it out or if chip clip arrives in the mail

Using FPT from Intel ME System Tools Intel Management Engine: Drivers, Firmware & System Tools

Made a CLOVER USB and booted into EFI shell.

Make sure tools are in the root path of the USB, otherwise you’ll have path troubles and the tools may say file not found.

ex:
USB:\FPT.efi => OK
USB:\Tools\FPT.efi => may cause problems


In EFI shell I was able to dump the DESC, BIOS, GBE, and PBR .

ME did not work but I backed it up before flashing a new firmware with the ME FW tool fom HP Firmware update: https://ftp.hp.com/pub/softpaq/sp82501-83000/sp82684.tgz



Tried to flash the original BIOS from above + NVMe DXE I added in with:

FPT.efi -BIOS -F bios.bin

but I got error:

Error 28: Protected Range Registers are currently set by BIOS, preventing flash access.
Please contact the target system BIOS vendor for an option to disable Protected Range Registers.

So it looks like the only way to flash it is by writing directly to the chip with a SPI programmer.

@e97 - 22.3 is very old, would not use that for anything now. Use 25 or 26, watch padding file messages and always check pad files above/below microcode volumes too (not always a message about these)
Check before/after in UEFITool NE version too, side by side, make sure parser messages look exact same, if not inspect or have someone look it over.

Error 28 can be bypassed a few ways, sometimes. First way, put windows to S3 sleep for one minute, wake it up and try FPT flash again from within windows (This will not work for USB DOS or EFI as you mention above)
If you do not have windows setup, you can try PRR tool here, use PRR2 - http://s000.tinyupload.com/index.php?fil…820996838218649
Create DOS bootable USB, with DOS FPT (all files from DOS Folder) on root of USB, along with your BIOS region file. Run PRR2.exe and when it’s done, try to flash BIOS region.

If those methods both fail for you, and there is no ME/FD/FDO/Service 2 pin jumper on this system then yes you will need to use programmer.

@Lost_N_BIOS
I’ve never successed in HP mobo by prr or prr2 when met Error 28.
May be it would be OK by this “sleep” method,I’d like to try~haha,Should I kept the CMD windows opening before sleeping?

@gloobox - sleep method only works if BIOS bug present, CMD window open before or after sleep doesn’t matter.

@Lost_N_BIOS
What you mean I think is the bug may be existed in the particular model or bios version?
I ever tried HP 600g1dm(FDO jumper was connected) and Z820 but all failed,and they were the newest bios version.

Btw,do you know what model or bios version could be ok by this method?Thanks~~

It’s an old BIOS bug, this S3 sleep getting around error 28 FD lock. Some BIOS have it and some do not, across all boards/models/brands.

Any system with FD jumper you do not need to use that trick, or any other, FD jumper will unlock FD and then you can write in unlocked FD and remove jumper.

You have programmer anyway don’t you? if not, I see you help with mod BIOS, always playing with mod BIOS, best you pickup a set of programmer + Clip + U Type chip extractor so you’ll have it all covered, it’s very cheap to get these if you order from China and wait it out

Some systems people swear you need programmer to flash, and that’s not always true either, sometimes you can via grub unlock things aside from BIOS lock and this removes other locks too (SMI/SMM/FPRR lock - FPT error 260-28x I think)
Error 28, only way around is jumper, Sleep big if present, or programmer. Sometimes if BIOS can be flashed by AFU certain AFU will get you around that too if you can find working version to flash in mod BIOS.
This lock can also be present in BIOS region, not part of the FD, set via FPRR lock aside from BIOS setting, often in PCHInitDXE module but sometimes in others too (usually tough to find, and best if user has programmer if you try to remove this one, unless it’s easily found in proper common location/format)

Hi all.
I am new to this job. Have no experience in modifying any BIOS system. Sometimes flashed few firmwares in SAT decos.
Now I have a second-hand Z620 workstation and I am beginning to investigate how to support NVME devices to boot.
The device is recognized by OS but not by bios to boot.
The bios installed is 3.95 and the latest on HP support webpage is 3.96
Has anyone been able to get it?
Thanks in advance any advice or help.
JP

@jpmiranda - So, I did post FPT info, but to the other thread you linked me to first in PM - HP Z620 workstation bootblock update

however, due to what’s mentioned above here, you need hardware flash programmer (like CH341A) Then BIOS needs dumped from chip, sent to me for edit, then you program back.
Let me know if you need linked examples to these hardware programming tools, you need CH341A programmer or similar and SOIC8 test clip w/ cable.