[REQUEST] Panasonic Toughbook CF-19 Mk6 unlocking SATA3

I have a Panasonic CF19 MK6 and i need also to mod BIOS for enable SATA 3. It is downgraded by manufacturer to SATA 2. Can you help me Mr. Lost_N_BIOS ? Thanks.

The 19 Mk6 should share the same mobo as the Mk7, so the same UEFI variable should work.

Should, as in I have no idea since I don’t own a Mk6.

Same CPU, it has also QM77 chipset…i dont see in Boot section from BIOS "UEFI Boot" and "UEFI Priorities" options…but in HWiNFO32 it say it is UEFI capable.
My BIOS version is V6.00L14 (latest version for MK6) and Intel ME fw version is 8.1.72 Build 3002

Wait until Lost_N_BIOS replies asking you to dump the BIOS so he can dump the UEFI vars, then you can change the SATA speed variable to let your 19 run at SATA3.

Oh, and get yourself some 1600 or 1866 MHz RAM modules, the HD 4000 iGPU absolutely loves high speed RAM.

I posted in this thread as it is basically the same device (i really don’t know real differences as also CPU is Core i5 3320M Ivy Bridge) maybe some hw revisions?

The 19 Mk6 should have the same mobo as the Mk7, only the CPU differs.

Other than that: idk!

Right! Core i5 3340 vs Core i5 3320…both Ivy Bridge platforms…

Hello to everyone ! I have a Panasonic CF19 MK6 and i need to mod BIOS for enable SATA 3. It is downgraded by manufacturer to SATA 2.

So first i dumped BIOS with fptw (i also attach dump here). I noticed that when i write back BIOS i get "Error 280: Failed to disable write protection for the BIOS space!" . Seems that my BIOS is locked (or sort of write protected mechanism).

Info about system: Panasonic CF19-MK6
Computer Brand Name: Panasonic Corporation CF-191G-50DE
Motherboard Chipset: Intel QM77 (Panther Point)
BIOS Version: V6.00L14
Intel ME Version: 8.1, Build 3002, Hot Fix 72

How can i disable write protection on my BIOS and how can i enable SATA 3 in BIOS ?

biosreg.zip (2.72 MB)

@bubu782001 - please see below for how to dump BIOS region with FPT, once you do that send me the biosreg.bin file and I will give you variable to use with this guide for grub/setup_var
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder.
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required

Hi Lost_N_BIOS. Here is my dump of BIOS region, made with FPT.

biosreg.zip (2.72 MB)

Thanks, I will move this over to your thread before we continue

* Edit @bubu782001 - Please see this guide, start at step 6, and using the info below make the following change
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename your .efi file too >> Shellx64.efi

At grub prompt type the following >> setup_var 0x11A 0x3

Lost_N_BIOS, the problem is i dont have .efi file. Where can i find that file ?

Here are my BIOS pictures, and Hwi screenshots. It seems like in my BIOS UEFI is deactivated from factory.

Screenshots.zip (1.44 MB)

It’s in the guide I linked (at bottom, attached in package with other tools)

Should i use .efi file from your guide?

Yes, please my reply above. Additionally, if you want to add more thoughts, or ask a new question etc, and no one has replied yet, please edit your post and add the new info instead of making a new post, thanks

Nope…it doesn’t work.

I think UEFI is not active in my BIOS. I rename to Shell.efi file and try…and also i try with Shellx64.efi. Same result.



What should i do next ?

Follow the guide, you need to choose “Launch EFI Shell from filesystem device” from exit page of BIOS, and ONLY Shellx64.efi name will work

USB should be formatted to FAT32, if it’s failing with USB Initialized as GPT, then make it MBR instead, and if it’s MBR and failing, make it GPT instead. I don’t think GPT/MBR matters, but it might.

I don’t have “Launch EFI Shell from filesystem device” option. In fact i dont see any EFFI or UEFI options in my BIOS.

Show me an image of the exit page of your BIOS

Sorry for late answer (i was at work)