ROG STRIX H270F GAMING hpet and xhci option missing

Hi, i know its an old motherboard but i wonder is it possible to unlock HPET and XHCI options on this motherboard ? Im having some serious problems with input lag because of xhci

Thanks in advance :slight_smile:

edit:forgot to mention i have the latest bios, version:1205

@AlphaTheFirst - Can you see PCH Config page in Advanced?

What XHCI Options do you need? Show me image of Advanced >> USB, so i can see what you can already see.

Thank you for your interest :slight_smile: i took some screenshots(some extras aswell just in case)
These are from my bios, the option i need is XHCI Hand-off and HPET’s name is just HPET i think :slight_smile:
edit: deleted unnecessary attachments

Please remove attached images, and put them into a zip. I do not need images from other boards, so leave that out, nor do I need extra images (only what I asked you for). And answer the questions I asked you in my reply above

Sorry, i thought they might help you, my bad. Yes i can see PCH Config page in Advanced, the options i need are XHCI Hand-off and HPET
I added only two images below, first is Advanced >> USB , second is Advanced >> PCH Configuration

h270bios.rar (307 KB)

Thanks! This board does not have USB Flashback, so this is the best way to flash mod BIOS, do not send me biosreg.bin yet, unless you get success at step #2 right now. Show me error at Step #2
HPET is called High Precision Timer in your BIOS BTW This and XHCI Hand-off easy to make visible for you, but we have to first do a dance around locks blocking you from flashing in mod BIOS.

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Since i have limited knowledge about these stuff i have to ask ; I did everything right until i type the following command " FPTw.exe -bios -d biosreg.bin " when i typed that it said
Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2019, Intel Corporation. All rights reserved.

I dont know if this is how its supposed to be since i couldnt see "biosreg.bin " anywhere afterwards.
My M.E version was 11.8, so i installed and tried to use Intel CSME System Tools v11 , tried v12 still same.
I also flashed my bios to latest again to make sure, but nothing changed.

edit: After too many tryouts i think i managed it through DOS, i used this 2 commands and please correct me if im wrong
FPT.exe -bios -d biosreg.bin
FPT.exe -desc -d fd.bin (These 2 worked flawlessly and i have both .bin files in usb now) BUT;

At some point i used FPT.exe -bios -f biosreg.bin instead of FPT.exe -desc -d fd.bin in DOS by mistake , it gave me error 368 but i think that was because i used wrong command ?
I added the pictures, i will add .bin files if you say everything is fine so far :slight_smile:

Commands.rar (5.88 MB)

@AlphaTheFirst - Yes, that is how it’s supposed to look while it works If you follow the directions exactly as outlined you should not have any issues, nor be forced to use DOS either (it’s fine to use DOS, but you don’t have to)

biosreg.bin will be created in the folder that contains the exe you run. You use ME System tools V11 ONLY

Error 368 is expected, this is what I wanted to know when you do step #2 This means BIOS Lock is in place and you have to disable it before we can flash mod BIOS
Please be VERY careful using FPT, you can brick your board with one wrong click!! Only do exactly and only as instructed!!

I do not need any of the above files, after you undo the BIOS lock, you will create a new biosreg.bin file and this you will send to me (throw out previous now, or move it somewhere else out of FPT folder/USB we do not want it)

Follow this guide I created just for this purpose, you can start at step #6, because I’ve done 1-5 for you and info is below
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename your .efi file to >> Shell.efi

BIOS Lock Variable to change >> 0x8E5

At grub prompt, type the following and hit enter, case sensitive >> setup_var 0x8E5 0x0

Once it’s done, reboot, and do the FPT step #1 and #2 again from the spoiler, this time #2 will succeed. Be sure you create a new BIOS region and have moved or deleted your previous, to make sure, use the commands below
1. FPTw.exe -bios -d biosregnew.bin
2. FPTw.exe -bios -f biosregnew.bin

Once you see success at #2, send me that biosregnew.bin file and I will make the settings you wanted visible

OK i changed BIOS Lock Variable and it was succesfull adding image in attachment just to make sure (i will remove after you check) i cant do step 1 and 2 from windows just like i couldnt before, it just says
Intel (R) Flash Programming Tool. Version: again, so im gonna do it in DOS just like i did with first step ?

Successful.rar (3.28 MB)

@AlphaTheFirst - grub looks good, I knew you could do it

On FPT, show me what you are doing in windows, show me the full window so I can see title bar too. Sounds like you are either not running as Admin, or you are not at the correct location with the CMD prompt
But yes, if you want, you can go ahead and do in DOS if that is easier for you, it’s not an issue to do from there. Remember to delete or move the old BIOSregion so you don’t mix it up with the new one, we only want to use the new one now with the change you made to disable BIOS Lock.

Ohh, and here is how to put image into thread using same way you attached rar above - [Guide] How to insert pictures or attach files to a post




I dont know why it did this again ? I thought i removed the lock.

@AlphaTheFirst - please resize any images you attach like that again, no need for 3-5MB images here
Looks like you have wrote in BIOSreg.bin from previous dump, or flashed stock BIOS, after you did grub, before you tried this again. Toss out that BIOSreg.bin file, redo grub again, then redo FPT stuff again using new file name, so there is no mixups

Additionally, go ahead and make sure this is also disabled while in grub

So >>
setup_var 0xEE1 0x0
Then enter
Then >> setup_var 0x8E5 0x0

Then reboot and do FPT #1-2

I think its done now, i did already deleted old biosregs but i dont know , maybe that 0xEE1 helped, i guess we will never know :slight_smile:
I attached biosnewreg.bin(finally lol) and image to show you that ;
FPTw.exe -bios -d biosregnew.bin
FPTw.exe -bios -f biosregnew.bin was succesfull(to guarantee), and i must say i admire your patience Thank you for helping me this far already for just 2 options.

Can i delete them now so they dont confuse me for next step ?

biosregnew.rar (5.36 MB)

@AlphaTheFirst - Nice to see progress! Yes, maybe 0xEE1 did it, but that should have already been 0x00 anyway, I only added that to be 100% sure.
You’re welcome, and it’s OK, I try to help best I can when i can!

Here is BIOS with settings you wanted visible, flash back in via >> FPTw.exe -bios -f biosregnewm.bin…828612797261517

You can delete if you want, but this file has different name, so should be no confusion (added m for MOD to name). Or, you can rename to anything you want, name does not have to be anything particular.

XHCI is there and OMG i cant tell you the difference in mouse lag when its disabled , im happier then ever now ! THANK YOU !
I think you forgot the High Presicion Timer tho i checked literally everywhere but couldnt see it
edit: Just realized when double-checking High Presicion Timer, XHCI also re-enables itself everytime i boot

@AlphaTheFirst - HPET is in Advanced >> PCH Config. If you can’t see, let me know, I will check again
* I found the issue! Here is BIOS with more XHCI options enabled too, maybe one of those is causing the auto-reset. There should be one more XHCI at Advanced (XHCI Legacy Support) >> USB and then more at Advanced >> PCH Config >> USB
One that caught my eye at PCH Config >> USB was this >> XHCI Disable Compliance Mode

Hmm! Give me some time on this one, having issue on rebuild now, previously it was easy workaround, but now it’s being a pain
I’ll keep at it, sometimes I have to walk away and then once I come back it rebuilds properly first time without requiring a huge dance around padding issue

@Lost_N_BIOS Let me know if you need more pictures from bios, i can only see XHCI in Advanced >> USB , no HPET or other XHCI’s sadly. Im already greatful for what you have done so far, and i got time so i can wait.
And sorry i didnt know my bios was so complicated but i learned one thing after i saw what XHCI did to my mouse even in that short time until boot; Never gonna buy asus mobo again !

HPET = High Precision Timer and it’s located at Advanced >> PCH Config, but if you do not see now, then it may be one of the issues I fixed the other day along with adding what I mentioned above, just need to find way to rebuild this BIOS without breaking it again
If you have flash programmer I can send you BIOS without that hassle to test and see if padding added/removed bricks your BIOS, if not you have to wait until I can fix properly.

Trying to redo it again now

@AlphaTheFirst * Edit - Got it See, just needed to walk away for a bit It’s such a painful dance sometimes
Some days I can try for hours to work around this issue and no luck, then next day Boom same stuff with fresh eyes / fresh try and done!

You should now see HPET (High Precision Timer) @ Advanced >> PCH Config
And there is now more XHCI options enabled too, maybe one of those is causing the auto-reset.
There should be one more XHCI at Advanced (XHCI Legacy Support) >> USB and then more at Advanced >> PCH Config >> USB
One that caught my eye at PCH Config >> USB was this >> XHCI Disable Compliance Mode

@Lost_N_BIOS I dont have to do all the steps again right ? All i have to do is FPTw.exe -bios -f biosregnewM2.bin ? I dont want to do anything wrong

Yes, that is correct