Which ME version for Socket 1151 Xeon CPUs on 100-/200-Series?

Used to replace CON ME.
Need to cooperate with ME cleaning tool. Can solve 100, 200 series motherboard using 8, 9 generations of CPU memory can not overrun and can not identify the problem! It also supports 1151 Xeon CPU series. (304 KB)

Edit by Fernando: Thread title shortened

1 Like

I don’t understand what you’re saying. If you are talking about me_cleaner, I don’t provide support for it. Instead, you can open an issue at its developers’ github page.

When you plan to use E3-21XX CPU on Z170 or Z270 motherboard, you can use this modified ME and disable ME. It can provide better compatibility.

1 Like

@shixinyuan :
Please shorten your chosen thread title. It is much too long. You can do it by editing the start post.

Use me_cleaner to cut COR SKU ME FW, whitelist MFS, and it will become 2.5MB.It can be put into ASUS/MSI’s flash chip, but other need change flash chip from 64Mb/128Mb to 128Mb/256Mb for larger ME Region.
Now remove FF at the end of FTPR partition. Move MFS forward to make ME FW less than 2MB so that it can fit every motherboard’s Flash Chip. That’s what @shixinyuan have done.

The reason for this is we found COR SKU ME with Reserved bit can run Xeon on non-C PCH.

good job! thank u all!

i do understand you the way, that Xeon E3V5 / V6 are not supported by that firmware? And the important question: where ist this FW derived from? Can’t find it in 11.8 FW archiv.
Best wishes

@pow - all ME FW 11.8.xx versions is in ME FW 11.8 (r23) repo here - Intel Engine: Firmware Repositories

1 Like

@Lost_N_BIOS thanks for your fast reply,
in the mentioned rarchiv is just one file which, based on the name, comes close to the one of @shixinyuan (7.0 MB)

theres no or a file 2.1 MB in size.

Did i use the wrong rarchiv?
Thanks so far and best wishes

Hi, I’ve been using this mod for my Xeon E-2246G on Z370 for quite sometime with no issue at all until I change to Asrock B365 Pro4 recently. I was able to mod/flash/boot up as usual but one of the pcie x16 slot is not working (first boot using xeon on this new board) I ignored the problem since I only use one slot anyway until later on the second pcie x16 slot stop working out of sudden. I have tried reinstall windows/reflash bios/check hardware connection/reinstall drivers, basically repeated every steps at least twice, tear down the whole parts and reassemble, reflash, reinstall etc but nothing seems to fix the issue. I have tried using different Me version but only the Cor HDA version able to boot up. Hwinfo shows no WHEA error but the DMIDecode area shows incorrect PCIE slot info, where the Slot Data Bus Width: 16x / x16 shown as Slot Length: Short and Slot 1x / x1 shown as Long. Not sure if this is indication of any issue with bios or driver/system, any opinion is very much appreciated. I have attached my bios dump here just in case it’s needed.

B365MP44.20_xeon.rar (8.76 MB)

@pow - Link me to your BIOS, so I can see what you are looking at on the current BIOS. The name of the ME FW in the first post has nothing to do with what you should choose for your system
Maybe I’m confused on what you wanted/asked? If you want the file from first post, it’s there attached.

Latest corporate one in the repo is, this should be in the package you downloaded. Corporate ME FW will not be 1.5-2MB, it’s generally or always 5-7MB+
From what he mentions, it sounds like you also need to disable ME FW via HAP bit in FITc (ME Kernel >> at bottom >> Reserved >> Set Yes) while you do the settings transfer, before you flash it into your board.

And @shixinyuan - can you please confirm, is that the only version you know to work, and others fail, or is that the only version you tested and disabled ME FW so you know it works?

@evonnewoon - sounds like faulty motherboard, bad slots, or damaged CPU or CPU socket pins, or damaged PCH maybe.
Or, it may be you are not transferring settings properly from your original ME FW into the new ME FW before you flash it in there (This is 100% a MUST DO THING)

@Lost_N_BIOS Thanks for the reminder on transferring the ME FW settings, I might have forgotten to repeat this step when I was rebuilding the whole thing, will try it now and update on the outcome once its done.

@evonnewoon - You’re welcome! Hopefully that is the issue with your PCIE slots! You always have to do that, can’t just stick in stock RGN or it will mess up lots of stuff usually, unless you flash in with ME FW Update tool.

@Lost_N_BIOS Thanks a lot. You nailed all information i was searching for. Albeit I was able to puzzle some information together by searching the thread you mentioned and taking a look on station-drivers. But i have one last question: What does DA D0 mean? Or what are the differences between them and can i substitute one with another if cleaned?

Does the following quotation mean PCH Stepping D0 is the same as DA?

(from Intel Management Engine: Drivers, Firmware & System Tools)

@Lost_N_BIOS Unfortunately it didn’t work, still the same as described previously. I have tried using ME FW Update tool as well, but nothing seems to be working for now. Besides the both Pcie x16 slots, the first M.2 slot is not working at all. The second M.2 slot however can only support SATA mode which my SSD is plugged into but not the Optane. Hwinfo shows that all my Pcie slots and M.2 slots are empty when I’m actually using one of the M.2 slot with my Sata Ssd. Hoping someone could shed a light within this issue.

Is there a way to operate 1151 Xeon gen 6 and gen 7 on say, an HP 600G2 without surestart dual bios?

I’ve got some 50 of these here waiting to accept another 50 xeon 1270v5’s.

I get error 15 when I build with Intel FIT, but I sus that it’s because I need to clean insert a new ME firmware region or need the exact same tool version as the ME which should be 11.something

can someone downsize the latest ME firmware corporate for me

MEFW.rar (518.4 KB)

1 Like

Thanks @dsanke.
Unfortunately this version MEFW.rar (518.4 KB) doesn’t work on Asus prime B250m-c (original bios 2001- ME con H) but it works with the ME version from the first post (304 KB).

when I compare these two regions, there are more partitions in yours, if they are partitions:
IVBP not exist in > (304 KB)
FLOG not exist
UTOK not exist
ISHC not exist

according to my test, the more partitions wont affect. and i can remove them too. here comes me fw with ftpr and mfs only. (316.2 KB)
and the modified bios with me fw in #18
PRIME-B250M-C-ASUS-2001.rar (4.6 MB)
the bios support all lga1151 or bga1440 cpu from skylake to coffee lake, not including skylake es(stepping below 3) or comet lake (stepping not 0xd)

1 Like