Z370N wifi kabylake processor!

I saw a previous post by @hitman20 looks like he had some success, I can not get in touch with him. Anyway his posts are almost a year old.

Can someone steer me in the right direction. @Lost_N_BIOS help I think you assisted before!

spi bios to large to upload


@snakeman I still have the BIOS running. I can do a dump with a SPI Flasher on the Weekend but I have to install the Tools again, because I didn’t need it in the past anymore.

@hitman20 Which processor are you running currently? Thanks for the dump.

Or, if you want to give some instructions I can give it a try.


@snakeman It should be a Intel Core i5 7400. I did it last year, I only now that I have used a older ME Version which also supports Kabylake. What I exactly did, I can’t tell you anymore. Sorry.

@hitman20 OK, I have a i5 7500 fingers crossed!

Here is the link for your topic:

Add Kabylake Support to Gigabyte Z370N

Old ME + proper ucode is probably all you need here, possibly byte edit at FD - programmer or unlocked FD would be required for easiest flashing
Reading his thread, looks like old ME Version w/ SKU switch (this edit is applied at FD, but all edits to ME FW / FD byte/SKU change done with Intel FITc tool) and confirm ucode you want is in there was all that was required
Ohh, and the GbePCIePortSelect change needed at ME FW too.

And, since this is Gigabyte board, FD probably 100% unlocked anyway, so you can write all via FPT (ie no programmer needed)

Dump your BIOS for me and I can do the edits if you want >> Check BIOS main page or MIT info page etc and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -d SPI.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -d SPI.bin)

Or, I can edit the stock BIOS so everyone can use it, if you want? If yes, please give me link to the BIOS version you want used.
If stock is used, only flash with Qflash. Do not FPT flash stock BIOS, and do not FPT Flash anybody elses BIOS either.

@Lost_N_BIOS Thanks, I will link only the F5 bios and the F12 bios the only two I’m interested in

http://download.gigabyte.eu/FileList/BIO…70n-wifi_f5.zip F5

http://download.gigabyte.eu/FileList/BIO…wifi_f12_v1.zip F12

Bios Dump using asprogrammer

Remove the zip extensions from each file and use 7zip to extract the bios file.

Sorry guys I named the file wrong it is indeed a Z370N wifi



Z370N_bios.spi.zip.001.zip (4 MB)

Z370N_bios.spi.zip.002.zip (2.63 MB)

@Lost_N_BIOS @hitman20 Did you guys forget about me?


It’s only been one day, sorry @snakeman - I’m very busy and always behind

Which BIOS do you want edited? I assume F12, but unsure why you linked F5 also?

Also, please clarify how you will be flashing, w/ Qflash so I can edit stock BIOS and anyone can use it by flashing with QFlash, or with programmer or FPT and only you can use this mod?
You may need to check, with BIOS F12 flashed in, does Qflash offer you Full or Quick BIOS update when you are there, or does it only offer to update the BIOS without a choice?
If it’s not asking Full or Quick, it may not update the ME FW, if this is the case you’d have to flash via FPT or programmer, or at least flash the ME FW via FPT before swapping CPU’s

Also, on your attached files, please clarify what exactly to remove, since there is two zip extensions in each file name and a 001 002 etc. What should each files name.extension be exactly
Or, upload as a single 7zip file to a free file host so I don’t have to try and figure that out, it’s never worked for me before so wasted downloads each time.

@Lost_N_BIOS I wanted both the F5 and the F12, I have performance issues only under Ubuntu with F12 wanted to test if using a i5 7500 will make any difference. I only included the spi dump just in case. Use the regular bios so anyone can use it if they need it. I will use qflash to flash the bios if it is safe. Just remove both the extensions from the file so the extensions are as follows .001 and .002. Use 7zip to unzip them to one file works great.

I am sorry to seem like I’m rushing. Hours seem like days when you are working on these projects!


@snakeman I have dumped now the BIOS via the SPI Flasher, please check if it works for you. The are the ME Version Info of it. YOu have to remve the .zip at the End of the File otherwise I think you can’t open it.


bios1.zip.001.zip (5 MB)

bios1.zip.002.zip (1.31 MB)

@hitman20 Thanks, but I think I will have all your info on my motherboard is that correct?

Mac address etc …

@snakeman I think you to try that if this is the case, because I never could test it on a other device. Otherwise you have to try to mod your BIOS yourself, that you have your own values.

@hitman20 I will give it a try and report back, after i do complete backups!

@hitman20 I can not open your files! I tried renaming them nothing helps. What did use to compress them?



@snakeman I have compressed it with 7-Zip. If it still doesn’t work with 7-Zip I will update it tomorrow again or upload it on a Filehoster.

@hitman20 bios1.001: The archive is corrupt


@snakeman Can you please try this one and remove the .zip at the end of the File?

Edit: I have uploaded it now to Sendspace. This is the Link: https://www.sendspace.com/file/6fzlq1 Password is snakeman.

@hitman20 That works thanks, They both work thanks.

Now to get up the courage and do some more reading!


See @snakeman - that’s why I cried when you had split files that needed renamed above too, it’s just not possible or a huge hassle due to the way this forum attaches and renames files as you download them.

If I modify stock BIOS, you can ONLY flash it via Qflash, DO NOT use those files with flash programmer or FPT. And yes, as mentioned, if you use hitman20’s files no matter how you flash it you will have his serial UUID and depending on how you flash it possibly his MAC ID too.
However, since you have programmer, you can easily backup your current BIOS, program in his and test, then program yours back. This way it doesn’t matter if you have his info in there or not, since you would only use for a short test period then put your BIOS dumped back in.

I will make stock F5/F12 for you, please remember to only flash them with Qflash… And, your links to gigabyte stock download are broken links. Please confirm your exact motherboard model and I will get them from the page myself.
Note to self >> confirm or add/UPD >> 906E9


F5 http://download.gigabyte.us/FileList/BIO…70n-wifi_f5.zip

F12 http://download.gigabyte.us/FileList/BIO…wifi_f12_v1.zip

These should be working,

Thanks for all the help


@Lost_N_BIOS Ok, I’m back @hitman20 bios worked only issue so far is ME driver under windows 10 so this has been great for testing my i5 7500
works in Win10 (me driver problems) Ubuntu 18.04.1 works

@hitman20 The bios flash worked my i5 7500 works. The bios version is F4. I have yet to work out my ME driver problem no big deal for testing.

Conclusions: The F4 bios boots 10-15 secs slower than F5 was, at boot up, other than that seems fine. I think the F5 and F12 might be faster.
Anyone have clues for the Me driver issues?



@Lost_N_BIOS I am having problems with ME driver, Could that stop me from using all the features of the processor … ex 3D hevc encoding?