PC shuts at exactly 29:41 uptime everytime - IME FW 0.0.0.0 in Bios

Hello,

Today I’ve kept trying and trying different ways to fix this issue that I’ve got. PC shuts down at exactly 29:41 system uptime. Considering the boot timing that would be 30 minutes.

My system is old but it still runs smooth for the thing I use it for.

Running on an Intel DQ67SW Motherboard with I5-2500.

I think I’ve found the issue but I need a solution. IME firmware is shown as 0.0.0.0 in Bios. In windows it was hidden. Uninstalled the driver hoping to install it again but what do you know, it won’t show at all nowa in Device Manager. I’m pretty fudged now.

Just ran a system full reset hoping the driver will be reinstalled.

I have updated my Bios to latest version 0070. Tried 0069 as well. Can’t go lower as Intel removed all support for this motherboard.

What do I do besides changing the motherboard?

Important! System shuts down even if I leave it in Bios.

I’ve tried unplugging my SSD. Left it there with the error saying there’s no operating system. Nothing. I’ve switched the RAM on all sides and possibilities. Nothing.

One thing that was weird. After removing the Graphics Card (GTX 1050) the system beeps twice - two times saying there’s no video output but doesn’t shut down.





Bios says: IEM FW 0.0.0.0

Device Manager had IME hidden. Made the mistake to uninstall it hoping to install it again but it just disappeared from the list after I’ve uninstalled it.

OK, so I’ve managed to have it working once by installing Intel INF Chipset Drivers. After a restart the issue reappeared and when trying to install Intel INF Drivers, I get an error saying “This platform is not supported”. The system broke after I went into Bios to change the boot device since I wanted to reinstall my OS. I think that making changes to Bios broke it. The change is not important, I guess.

One thing I’ve observed is that when the computer shuts down or restarts the HDD clanks like when you’d lose power all of a sudden.

Note: I’m just a beginner when it comes to Bios settings and everything related.

Cheers, A.

The ME firmware is probably corrupted. Run MEInfo tool from Intel Management Engine: Drivers, Firmware & System Tools > ME System Tools v7 with parameter “-fwsts” and show us the result.

Thanks for answering.

Here’s the output you’ve requests:
Intel(R) MEInfo Version: 7.1.50.1166
Copyright(C) 2005 - 2011, Intel Corporation. All rights reserved.


Error 9455: Fail to read FW Status Register value 0x0

Yeah, if it can’t even read the FW Status Registers, it should be corrupted. Run Flash Programming Tool with parameters “-i”, then “-dumplock” and then “-d spi.bin”. What are the results? If the last one succeeded, compress and attach/link to the spi.bin file.

The last command failed.

Output attached.

output.txt.txt (2.27 KB)

Ok, you need to repair the ME firmware. Unfortunately, the Flash Descriptor is locked so you do not have read/write access to the ME firmware region of the SPI/BIOS chip. Things will become difficult now. You need to unlock the FD first by following [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing, then dump the current/corrupt SPI/BIOS image via FPT with “-d spi.bin” parameter and finally clean/repair the ME firmware via [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization.

Thanks,

I’ll try and see what I come up to. Will post if I run into trouble, hope you’ll be here to help.

I will. The most difficult step is unlocking the FD and the guide covers all the possibilities.

I have found something related to resetting MEBX in the Motherboard Manual, Page 58 - attached.

Is this something related Unlocking FD?

dq67sw_techprodspec02.pdf (5.35 MB)

No, MEBx is not related to FD unlocking. From what the manual says, only “BIOS Setup Configuration Jumper” could be interesting but from its description it seems to only deal with BIOS. You could set it to Recovery mode, create a recovery usb with the latest BIOS (.bio format, consult the manual/internet on how to do that as I don’t know) and see if that has the capability to also re-flash the ME firmware region. Otherwise, you’ll have to follow the steps of the guide. Start with E2 (look at the motherboard for any non-manual-documented jumpers), E3 (look at the BIOS for any interesting options), E6, then move to E1 and the rest.

For your board you need to remove the bios jumper to get read/write access. And if that doesn’t work maybe need to change some UEFI variables to unlock everything. Have you tried the Intel recovery method using the .bio file with the jumper removed?




@plutomaniac Hivemind haha!

Ok, I’ll try removing the Recovery Jumper completely.

Will be back with an update.
--------------------

Great, removing the Bios Configuration Jumper worked and I was able to generate the spi.bin file using FPT.

Attached.

What do I do now?

spi.zip (4.64 MB)

All you need to do reflash the ME region from fully working image. Plutomaniac pointed you to the right threads to get that done since you need a cleaned up one. You can probably get away with extracting the file you dumped in FIT and then after its unpacked replace the corrupt ME region file with a cleaned up one, build a new bin file and flash it.

Ha, typical case of the manual hiding the true nature of a jumper. “Resetting BIOS settings” is not the same as unlocking the Flash Descriptor. Anyway, as I said earlier, you need to clean/repair the ME firmware by following [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization. Once you have the repaired SPI image, flash it via FPT with parameter “-f spi_fix.bin” followed by “-greset”. If you want, upload the output of the guide to check if you followed it properly before flashing it back.

For what I see there are different points ‘Dx’ for different versions of ME. I remember needing ME 7, should I only proceed with the steps for D3. ME 7 - 10 & TXE 1 - 2?

Yes, follow the ME 7 steps of course

@plutomaniac Offtopic here but I used your ME region only bin file to add AMT to my 7020. Thanks for that! Worked like a charm. It was a good learning moment too. I’ve since updated the ME region again because yours seemed to be in German or maybe that region was set elsewhere. It’s English now


Indeed off-topic, so let’s not expand further on this, but I’m glad that helped. The AMT/MEBx language is set via FITC so that user was probably using the German one and it got transferred with the configuration settings while following the cleanup guide and enabling AMT at the same time.

I’m at the final steps but when trying to flash the new outimage.bin I get:
Error 280: Failed to disable write protection for the BIOS space!

Any way to fix this?

Yes, that is an extra BIOS protection measure, aside from FD. You can flash the ME region of the SPI/BIOS chip only. Download UEFITool Axx release, load outimage.bin and “Extract as is…” the ME region. Then use FPT with parameter “-me -f me.bin” followed by “-greset”. Don’t forget to reset the jumper when you’re done. After the reboot(s), run MEInfo -verbose and show us the result.