[TOOL] Easy automated Mod tool for Coffee Lake bios

since our win-raid already have some thread about run CoffeeLake on 100 and 200 series MB

[GUIDE] Coffee Lake CPUs on Skylake and Kaby Lake motherboards
Fixing PCI-Express for Coffee Lake CPUs on Sky/Kaby Lake non-Asrock(and some new Asrock) motherboards
[GUIDE] Fixing HT for Coffee Lake CPUs on Skylake and Kaby Lake motherboards (Z170, Z270)

So i made a tool auto generate BIOS what youneed

the feature include



How to use:
Add program to your antivirus whitelist.
Double click “AllinOne.exe” and select your bios for mod, or drag your bios on AllinOne.exe to execute.
If you have K processor, drag bios on “x.SyncAllCoreRatio.exe” to enable OC function properly.
If you want disable HT function by default, drag bios on “x.DisableHT.exe”.

How to FLASH:
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash
[Guide] Using CH341A-based programmer to flash SPI EEPROM
[Guide] How to flash a modded AMI UEFI BIOS
Flashing Gigabyte while avoiding "Invalid BIOS image"


Identify your cpu stepping

CFLMOD.jpg



Known issues
1. Asus 100 series 2xxx version bios can support up 16 threads, 200 series please try version under 1xxx for 12 threads.
2. MSI board bios can support up 8 threads.

[Warning]
1.this tool only help you mod bios,not include flash,read other post in this forum for more information.

Tool written in batch and autoit 3,convert to exe file ,so some antivirus report it dangerous, if you can’t trust, please give up.


Change log


-[update-01]-
fix some error handle.

-[update-02]-
2018-09-26
change bmp window handle,remove lock keyboard and mouse.
download “update-01.zip” and extract.

-[update-03]-
2018-09-28
support more acpi fix
update vbios gop update program

-[update-04]-
2018-09-28
update vbios gop update program

-[update-05]-
2018-10-08
more bug fix
change microcode replace method

-[update-06]-
2018-11-06
fix vbios update miss file error
add Q series chipest support (COR MEFW)


2019.311
Add rename function,out bios filename will be brand_board_modfeature.
Add multiple vbios update process in MAXSUN and other brand,update vbios version to 1062.
New microcode replace method.
Use UEFIExtract new engine version for acpi table extract.
Fix wrong guid in pcie patch.
Use Descriptor 0x307 hack for U0 P0 stepping support,no longer use change sku by default,use x.skuz370 if you want.
Update to latest microcode.
Add Hyper-Threading disable program for test purpose.
Add all core adjust patch for OC purpose.



Download link:



[[File:???01.jpg|none|auto]]

???01.jpg

1 Like

Change SKU not always needed, and sometimes cause issue, is this function optional?

Thanks for your work, I’m sure lots of people will appreciate all the effort you put into this!

yes,[[File:???01.jpg|none|auto]]

???01.jpg

Really incredible work , you are our savor !

Hello!
I have a problem that when I type a file into a script, an unexpected error occurs and the version of me bios 1 what to do?

Motherboard: Gigabyte GA-Z170-HD3 DDR3

BIOS: F21F

Are there any dependencies for this to work?

I was getting C++ errors from mmtool, "run-time check failure #2 - Stack around the variable ‘Cl’ was corrupted."

I replaced the included mmtool 5.02.0024 (modded) with mmtool 5.0.0.7 to get around the C++ error.

It then gets stuck at the VBIOS step, the ssf.exe script starts then Intel BMP opens and nothing happens.

I have tried loading the skl_1059.dat data & skl_1059.bsf script from the resources folder and manually selecting my transfer.ssf script (from my motherboard BIOS) but Intel BMP just closes without applying my settings and ssf.exe is paused in the system tray with the command prompt window also paused waiting for ssf.exe to finish.

I bypassed the VBIOS mod and the process continued to the end without patching the GOP.

[Edit] I don’t get the modded mmtool (5.02.0024) C++ errors on Windows 7 (32-bit), only on Windows 10 (64-bit) 1803.

I tried patching the VBIOS and GOP on my laptop but I get the same result, ssf.exe script paused and Intel BMP opens and does nothing.


thank you for feedback

ssf.exe use to automate gop and vios update, written in autoit3, simulate mouse and keyboard actions,i tested only in win 7, so maybe have some incompatible.
what resolution and dpi scale level are you using ?do you using antivirus?
i will test later

otherwise,dray bios on other single exe can do step by step process(new file will generate in same directory)


reason is filename of bios have space,i’ll fix later

I’m using a standard 1080p monitor with 100% scaling.

I’m using Windows Defender for antivirus, the only file it complained about was @6skuz370.exe, so I set it to allow.

It might be worth splitting the VBIOS & GOP update into two separate exe’s for troubleshooting.

So we can test the vbios batch first;

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
 
echo Ready update VBIOS...
:start
set vbios_ver=1059
 
del "%~dpn1".*vbios.* 2>nul
start /min /wait mmtool "%~dpnx1" /e /l "%~dpn1.vbios.dat" A0327FE0-1FDA-4E5B-905D-B510C45A61D0 C5A4306E-E247-4ECD-A9D8-5B1985D3DCDA
for /f "tokens=*" %%b in ('findver "" 2456425420534B 79 FF 4 2 "%~dpn1.vbios.dat"') do (
ssf "%~dpn1".vbios.dat %%b
if not exist "%~dpn1.vbios.dat.ssf" echo retry...&&goto start
sed "/STRING \$Signon/d" "%~dpn1.vbios.dat.ssf" >"%~dpn1.vbios.ssf"
if %errorlevel% neq 0 echo error&&pause
unix2dos "%~dpn1.vbios.ssf" 2>nul
bmp -s "%~dp0\res\vbios\%vbios_ver%\skl_%vbios_ver%.dat" "%~dp0\res\vbios\%vbios_ver%\skl_%vbios_ver%.bsf" "%~dpn1.vbios.ssf" "%~dpn1.vbios.%vbios_ver%.dat"
 
echo start update vbios...
start "updating vbios" /min /wait mmtool "%~dpnx1" /r /l "%~dpn1.vbios.%vbios_ver%.dat" A0327FE0-1FDA-4E5B-905D-B510C45A61D0 C5A4306E-E247-4ECD-A9D8-5B1985D3DCDA
del "%~dpn1".vbios.*
echo Done^!
 


then the GOP batch;

1
2
3
4
5
6
7
 
echo Ready update GOP...
:start
set gop_ver=1080
 
echo start update gop...
start "updating gop" /min /wait mmtool "%~dpnx1" /r /l "%~dp0\res\intelgop%gop_ver%.efi" A0327FE0-1FDA-4E5B-905D-B510C45A61D0 380B6B4F-1454-41F2-A6D3-61D1333E8CB4
echo Done^!
 


not working on win7, working now, it require absolute path to bios :slight_smile:

found problem in controling intel BMP, it hooks keyboard and mouse and just hanging, no actions on menu, only ctrl+alt+del helps
- ssf run with "%~dpn1".vbios.dat, maybe "%~dpn1.vbios.dat" ?
- bmp started by ssf with no parameters, but later in @2gop_vbios.bat i see it started with some parameters

Good job! Thanks!

Zitat von Mov AX, 0xDEAD im Beitrag #10


not working on win7, working now, it require absolute path to bios :slight_smile:

found problem in controling intel BMP, it hooks keyboard and mouse and just hanging, no actions on menu, only ctrl+alt+del helps
- ssf run with "%~dpn1".vbios.dat, maybe "%~dpn1.vbios.dat" ?
- bmp started by ssf with no parameters, but later in @2gop_vbios.bat i see it started with some parameters




i will check later and fix this problem,thank you for your feedback

file reupload,please try again
this bios z170-hd3-ddr3 f21 i have tested,no error happen.
sometimes mmtool c++ runtime error,but i dont know why,so i change the process order.

I tried the new version but it does the same thing, hangs on BMP opening and the mouse doesn’t move, have to Ctrl+Alt+Del on my laptop to regain mouse control.

Tried on both Windows 10 x64 (desktop) and Windows 7 x86 (laptop).

I did manage to run the modded mmtool 5.02.0024 without getting the C++ error but I don’t know what causes it.

Using mmtool 5.0.0.7 I noticed there is no BIOS ACM entry & Bootguard Key Manifest is also not implemented, although the Firmware Interface Table (FIT) seems to be ok.

I’ve got the same problem on my computer, mouse just freezes and nothing happens after that.
Asrock Fatal1ty Z270 Gaming K6 and windows 10 x64.

i think maybe window title or position handle error
could you please run bmp.exe under bin dir and load a dat from src vbios ,then take a screenshot and upload here。

should work now.

It’s still doing the same thing and hanging on BMP.


I clicked the bmp window,It continued!

Could u add the colorful maxsun soyo vbios mod file?
GUID:
58B6E809-808B-4C26-BC0A-BFD7B770D721
B981F167-9D2B-4CA0-82E9-63DF0E3C3BF3
9AECBA5E-37ED-4A37-83C7-0F73FB34B5DB
B92571E7-739B-4B2C-B6AF-CEC02A209C86
9B703B6F-90B2-4E8A-A80B-932ECD1F8801

Thanks!